Minimal required version of Flash player is 9. Please, DOWNLOAD IT NOW